Deployment of D10 3.17.0 is complete for production sites and is now commencing on non-production sites. The deployment block has now been lifted.
Posted Sep 17, 2024 - 13:26 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2024 - 06:00 AEST
Scheduled
Advice - Who is affected: GovCMS Drupal 10 (D10) community. - Distribution was updated on Monday 16 September 2024 . - No modules were added/removed from the distribution - No outages are expected to websites during the deployment process. - The D10 distribution will continue to be supported after this update. - If you have any concerns, raise a ticket at https://www.govcms.support
Deployment schedule plan: - Commence from 6:00AM (AEST) Tuesday 17 September 2024 - Production branches completed by 10:00 AM (AEST) Wednesday 18 September 2024 - Once production branches are completed, status page will be updated and Non-Production branches will kick off - Non-Production branches should be completed by 10:00 AM (AEST) Thursday 19 September 2024
❗ IMPORTANT NOTICE 1: Deployments during maintenance window - During the scheduled maintenance window, ALL D10 SaaS deployments will be blocked while we deploy to the D10 Production branches. - While the production block is on, you will still be able to develop and deploy to non-production feature branches. - PaaS deployments schedules are not impacted.
❗ IMPORTANT NOTICE 2: Update local environments - Ensure you update your local environments to the latest release. Not rebasing your codebase results in mismatched database configuration causing errors in forklifts and deployments.
❗ IMPORTANT NOTICE 3: For customers with configuration management enabled - The latest configuration from your production database has been created for you in GitLab in a branch called action-required/latest-config-export. - You need to review and test the changes in the merge request. Once you are satisfied, please check the “Delete source branch” box and click “Merge”. - This MUST be done before any new commits. - All subsequent deployments will be blocked in the CI pipeline until this merge request branch is deleted - Not merging the latest configuration provided could result in your new database configuration reverting to an older version when you next deploy, potentially causing issues for your website. - If no merge request is lodged after a release then no configuration has changed and no further action is required.
Information for PaaS customers - If you use the GovCMS D10 distribution, you should aim to apply this update to your distribution as soon as possible. - Updated files will be available from https://github.com/govCMS/GovCMS/releases/tag/3.17.0