Shipshape error causing deployment failures

Incident Report for GovCMS

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 13:36 AEST

Update

GovCMS is applying a fix to the commands to run the shipshape audits for all master and secondary environments for all SaaS projects.

PaaS customers, if you have updated to the latest lagoon image (10.3.6) - you will need to apply this fix: https://github.com/govCMS/scaffold/pull/120/files
Posted Apr 16, 2025 - 17:21 AEST

Identified

An update to Shipshape requires a fix to be applied to the scaffold. Until this happens, Lagoon deployments will fail with the following error:

"Executing task 'Perform GovCMS platform validations' in pod [POD-NAME]
Error: unknown flag: --error-code
Usage:
shipshape [command]
..."

SaaS customers will need to raise a ticket so the service desk can do this for them.

PaaS customers can apply the fix themselves:
https://github.com/govCMS/scaffold/pull/120/files
Posted Apr 16, 2025 - 13:31 AEST
This incident affected: GovCMS Projects (Deployment Infrastructure).