Deployment of D10 3.3.0 is complete for production sites and is now commencing on non-production sites. The deployment block has now been lifted.
Posted Oct 05, 2023 - 08:32 AEDT
Update
Deployment of D10 3.3.0 to production is now completed. The deployment block has now been lifted. We've kicked off non-production deployments, and they will run through the night and into tomorrow.
Posted Oct 04, 2023 - 21:12 AEDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2023 - 06:00 AEDT
Scheduled
Advice - Who is affected: GovCMS Drupal 10 (D10) community. - Distribution was updated on Tuesday 3 October 2023. - D9 and PaaS deployments schedules are not impacted. - No modules were added/removed from the distribution. - No outages are expected to websites during the deployment process. - The D10 distribution will continue to be supported after this update. - If you have any concerns, raise a ticket at https://www.govcms.support
Deployment schedule plan: - Commence from 6:00AM (AEDT) Wednesday 4 October 2023 and will be conducted throughout the daytime. - Production branches completed by 10:00AM (AEDT) Thursday 5 October 2023 - Non-Production branches completed by 10:00AM (AEDT) Friday 6 October 2023
❗ IMPORTANT NOTICE 1: Deployments during maintenance window - During the scheduled maintenance window, ALL D10 SaaS deployments will be blocked while we deploy to the D10 Production branches. - While the production block is on, you will still be able to develop and deploy to non-production feature branches. - PaaS deployments schedules are not impacted.
❗ IMPORTANT NOTICE 2: Update local environments - Ensure you update your local environments to the latest release. Not rebasing your codebase results in mismatched database configuration causing errors in forklifts and deployments.
❗ IMPORTANT NOTICE 3: For customers with configuration management enabled - The latest configuration from your production database has been created for you in GitLab in a branch called action-required/latest-config-export. - You need to review and test the changes in the merge request. Once you are satisfied, please check the “Delete source branch” box and click “Merge”. - This MUST be done before any new commits. - All subsequent deployments will be blocked in the CI pipeline until this merge request branch is deleted - Not merging the latest configuration provided could result in your new database configuration reverting to an older version when you next deploy, potentially causing issues for your website. - If no merge request is lodged after a release then no configuration has changed and no further action is required.
Information for PaaS customers If you use the GovCMS D10 distribution: - You should aim to apply this update to your distribution as soon as possible. - Updated files will be available from https://github.com/govCMS/GovCMS/releases/tag/3.3.0 - If you manage your own distribution, this core release should have been assessed and addressed.
Posted Oct 03, 2023 - 14:50 AEDT
This scheduled maintenance affected: GovCMS Projects (Individual websites).