CSS pre-processing order changed in Drupal core

Incident Report for GovCMS

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 16:56 AEDT

Update

The scheduled maintenance has been completed. All SaaS websites have successfully rolled back to 3.22.0 (Drupal Core 10.3.13) on all production environments. We are now commencing deployments to non-production environments. The SaaS deployment block has now been lifted. We recommend that you review your website, and if you’re experiencing issues, raise a Service Desk ticket (https://www.govcms.support/).
Posted Apr 02, 2025 - 02:39 AEDT

Update

Due to issues identified in release 3.23.0, GovCMS will roll back to release 3.22.0 (Drupal Core 10.3.13). The SaaS deployment block is now back in place while we deploy to the D10 production environments.
Posted Apr 01, 2025 - 20:14 AEDT

Update

Please note: The fixes suggested so far may not be effective on all sites, and further fixes may be suggested. You will need to determine which fix is the best solution for the issue your site is having, and which lines in the yml file to amend. Please consult your developer.

If you require assistance, please raise a ticket with the Service Desk.
Posted Apr 01, 2025 - 16:52 AEDT

Monitoring

Due to the switch from Drupal 10.3.x to 10.4.x, Drupal now processes assets in a different order to before, which may be affecting the visual presentation of some sites.

Please see https://www.drupal.org/node/3473558 for more information

GovCMS recommends affected customers apply one of these fixes, both are not required.

Fix 1. Add a theme dependancy:

global-css-js:
css:
theme:
css/styles.css: {}
dependencies:
- core/drupal
- core/drupalSettings
- core/jquery
- core/once
- CUSTOMTHEME/global-css-js #ADD THIS

OR

Fix 2. Add { weight :99 } to your library in the libraries.yml file

dropdown:
css:
component:
/libraries/bootstrap/dist/css/bootstrap.css: { weight: 99 }

If your site is affected and you require assistance to rectify, please log a ticket with the Service Desk.
Posted Apr 01, 2025 - 16:37 AEDT
This incident affected: GovCMS Projects (Individual websites).