Deployment failures on new environments containing 2 consecutive dashes

Incident Report for GovCMS

Resolved

This incident has been resolved.
Posted Jun 08, 2023 - 16:18 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2023 - 15:51 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 08, 2023 - 15:29 AEST

Investigating

We are seeing environment deployments with a git branch with 2 consecutive dashes fail. We are working on a fix. For now, as a workaround, you can push a new branch without 2 consecutive dashes.

e.g. instead of `feature/32365--new-banner` use `feature/32365-new-banner`

This impacts < 1% of non-production environments.
Posted Jun 08, 2023 - 08:00 AEST
This incident affected: GovCMS Projects (Deployment Infrastructure).