Deployment of D10 3.16.0 is complete for production sites and is now commencing on non-production sites. The deployment block has now been lifted.
Posted Aug 28, 2024 - 08:12 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2024 - 06:00 AEST
Update
Advice - Who is affected: GovCMS Drupal 10 (D10) community. - Distribution was updated on Monday 26 August 2024 . - No outages are expected to websites during the deployment process. - The D10 distribution will continue to be supported after this update. - If you have any concerns, raise a ticket at https://www.govcms.support
Deployment schedule plan: - Commence from 6:00AM (AEST) Tuesday 27 August 2024 - Production branches completed by 10:00 AM (AEST) Wednesday 28 August 2024 - Once production branches are completed, status page will be updated and Non-Production branches will kick off - Non-Production branches should be completed by 10:00 AM (AEST) Thursday 29 August 2024
❗ IMPORTANT NOTICE 1: Deployments during maintenance window - During the scheduled maintenance window, ALL D10 SaaS deployments will be blocked while we deploy to the D10 Production branches. - While the production block is on, you will still be able to develop and deploy to non-production feature branches. - PaaS deployments schedules are not impacted.
❗ IMPORTANT NOTICE 2: Update local environments - Ensure you update your local environments to the latest release. Not rebasing your codebase results in mismatched database configuration causing errors in forklifts and deployments.
❗ IMPORTANT NOTICE 3: For customers with configuration management enabled - The latest configuration from your production database has been created for you in GitLab in a branch called action-required/latest-config-export. - You need to review and test the changes in the merge request. Once you are satisfied, please check the “Delete source branch” box and click “Merge”. - This MUST be done before any new commits. - All subsequent deployments will be blocked in the CI pipeline until this merge request branch is deleted - Not merging the latest configuration provided could result in your new database configuration reverting to an older version when you next deploy, potentially causing issues for your website. - If no merge request is lodged after a release then no configuration has changed and no further action is required.
What modules are added/uninstalled/obsolete/removed in the distribution? The following modules will be marked as obsolete in the distribution: - Block Place (https://www.drupal.org/project/block_place) The following deprecated themes will be removed from the distribution: - Adminimal - Seven - Stable
Information for PaaS customers - If you use the GovCMS D10 distribution, you should aim to apply this update to your distribution as soon as possible. - Updated files will be available from https://github.com/govCMS/GovCMS/releases/tag/3.16.0
Please note that this release has been delayed. The expected release date is now Monday 26 August, with the deployment block being Tuesday 27 August.
Posted Aug 19, 2024 - 10:39 AEST
Scheduled
Advice We would like to inform you of the tentative dates for the upcoming GovCMS Drupal 10 (D10) release and deployment.
The final release date is subject to change, as it will be determined by the testing outcomes. The date will be confirmed when the distribution is released and the release notes are expected to be sent on Monday 26 August 2024 .
As a reminder, a SaaS deployment block is in place ONLY while we update the production branches. During this time, you will still be able to develop and deploy to non-production feature branches. We are wanting to give you as much lead time as possible, should you need to adjust your timeframes.
PaaS deployments schedules are not impacted.
Tentative deployment schedule: - Deployment to commence from 6am Tuesday 27 August 2024 and will be conducted throughout the daytime. - Production branches completed by 10am Wednesday 28 August 2024 - Non-Production branches completed by 10am Thursday 29 August 2024