Successful commits not triggering deployments
Incident Report for GovCMS
Resolved
A new GitLab feature meant webhooks were permanently disabled after returning certain HTTP status codes.

We've pushed out an update to the webhook handler to address this new behaviour. We've also reset the webhook configuration for all GitLab projects, so this should no longer be an issue.
Posted Jan 20, 2023 - 09:51 AEDT
Identified
We've identified the issue and are working on implementing a fix.
Posted Jan 19, 2023 - 10:03 AEDT
Investigating
We're currently investigating an issue with GitLab whereby commits and successful CI pipelines aren't triggering Lagoon deployments.

The issue appears to be that the webhook which triggers a deployment after a successful pipeline has been automatically disabled after failing too many times. We're investigating why this happened and how to prevent it happening again in future.

Customers experiencing this issue are encouraged to raise a support ticket about this so that we can re-enable the webhook for them and restore the ability to deploy their code/changes.
Posted Jan 19, 2023 - 09:14 AEDT
This incident affected: GovCMS Projects (GovCMS GitLab, Deployment Infrastructure).