Harbor Image Pulling Issues

Incident Report for GovCMS

Resolved

After a period of extended monitoring, we’ve confirmed that the issue has been fully resolved and normal service has been restored. No additional impact has been detected. As noted previously, if you believe any of your builds or deployments remain impacted, please contact the support desk to raise a ticket.
Posted Oct 28, 2025 - 20:11 AEDT

Monitoring

We have completed our resolution efforts for this issue, and cleared the backlog of failed deployments/rollouts. If any of your builds or deployments are impacted from here on, please contact the support desk to raise a ticket.
Posted Oct 27, 2025 - 16:47 AEDT

Identified

The source of the issue has been identified and remediation efforts are underway. The time to full resolution is not yet currently known. If you are having issues that you believe are related to this incident, please lodge a support request with further details so that further assistance may be provided.
Posted Oct 27, 2025 - 13:53 AEDT

Update

Harbor is where the containers are stored for environments. Builds build and push the images to Harbor, and then Kubernetes pulls those images when it runs the pods.
The current issue may impact deployments, which can be seen by deployments taking a long time and then failing on Pre-Rollout Tasks.
Additionally if a container needs to start up outside of a build, this also may fail.
Posted Oct 27, 2025 - 12:32 AEDT

Investigating

We’re currently investigating an issue affecting image pulls from Harbor.
Posted Oct 27, 2025 - 12:08 AEDT
This incident affected: GovCMS Projects (Deployment Infrastructure).